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Qutline

e Introduction to Imaris

 Getting Started

» Data Types- 3D and 4D, file formats
 Image processing

* Visualization methods

» Segmentation/Measurements
 Tracking

 Colocalization

e Animations



ﬁ Where do | access Imaris
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Imaris is available on PCs at

- Basic Sciences Computational Laboratory (BSCL),

1-280 BSBE

- Scientific Development and Visualization Laboratory
(SDVL),

575 Walter Library

- SDVLAppl- remote windows application server, which can
be connected to via Citrix



M ﬁ Supported File Formats
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Applied Precision, Inc: DeltaVision (*.i3d, *.dv)
Biorad: MRC-600, MRC-1024 (*.pic)

Bitplane: Imaris Series (*.ims)

Bitplane: Imaris Classic/Old (*.ims)

Bitplane: Imaris Scene File (*.imx)

Carl Zeiss: LSM 510 (*.Ism)

Carl Zeiss: LSM 410, LSM 310 (*.tif, *.tiff)

Carl Zeiss: Axiovision (*.zvi)

Image Cytometry Standard: ICS - used by Nikon, and others (*.ics, *.ids)
Leica: TCS-NT (*.tif, *.tiff)

Leica: LCS (*.lei, *.raw, *.tif, *.tiff)

Leica: series (*.inf, *.info, *.tif, *.tiff)

Olympus: FluoView TIFF (*.tif, *.tiff)

Olympus: FluoView 1000 OIF (*.oif)

Olympus: FluoView 1000 OIB (*.0ib)

Olympus: Cell™R 1.1/standard (*.tif, *.tiff)

Open Microscopy Environment XML (*.ome)
Scanalytics: IPLab (*.ipl)

TILL Photonics: TILLviISION (*.rbinf)

Universal Imaging: Metamorph STK (series) (*.stk)
Also supported are basic numbered tiff image series.



M ﬁ lmage sequences
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Working with Series:

* Asingle 2d image xy dimensions

A stack of 2d images Xx,y,z forming a volume

e Multiple stacks of the same sample, but depicting collected at different
frequencies ( multiple channels).

e Time varying series( the 4th dimension).

eg. xyz-chl-tl, xyz-ch2-tl, xyz-chl-t2, xyz-ch2-t2....and so on.
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File->Open->Select file
Reading Tiff Series:

* When working with a 2d
tiff image series, select

Loading Images in Imaris

by Becent
Documents

Fra

Dezktop

the first file, and Click )

‘Settings’ in the dialog

box.

by Documents

Look in; I_‘,l M T_Original

j inverted

LJ l@ inverted.ims

IET_massonood tif
[Z]MT_Massonnnz. tif
[BIMT_Massonnna. tif
[BIMT_Massorond. kit
[BmT_massonoos. tif
[BIMT_massonooe. tif
[B]MT_Massonnn?. ki
[BIMT_Massonons. tif
[BIMT_massonooa. i
[Z]MT_Massonnio.tif
[BMT_Massonn1 1.t
[BIMT_Massoroi 2.t

[BIMT_Massono13.tiF

(2] MT_MassonD1 4.t
(2] MT_Massan015.4F
[ 2] MT_Massann16.tF
|2 MT_Massann1 7.t
2] MT_MassonD18.tF
(2] MT_Masson019.4F
(2] MT_Massannz0.tF
2] MT_Massannz1.tF
(2] MT_Massonnzz.tF
(2] MT_MassonDz3.t
[ 2] MT_Massannz4.tF
2] MT_Massannzs. tiF
(2] MT_Massannze. b
2] MT_MassonDz7 b

(2] MT_Massan0z2a.4F

B s 8 5

[Z|MT_Masson029.tF
(2 MT_Massan030.4F
[Z]MT_Masson031.tF
[Z|MT_Massonn3z.tF
[Z|MT_Masson033.4F
[Z]MT_Masson034.tF
[Z]MT_Masson03s
[ZMT_Massonn3. tF
[Z|MT_Masson037.tF
[Z]MT_Masson038.tF
[Z]MT_Masson039.tF
[Z]MT_Masson040.tF
[Z|MT_Masson041.tF
[Z|MT_MassonD4z.tF

(2] MT_Masson043 4

[S]MT_Massani4d, i
[ZIMT_Masson045.1
[Z]MT_Massonide.t
[2)MT_Masson047.1
[Z)MT_Massonn4a.t
[Z)MT_Massono49.t
[Z]MT_Massonnso.t
[Z]MT_Massonns1 .t
ZMT_Massonos2
[ZIMT_Masson053.t
[Z)MT_Massonos4.t
[2)MT_Massonnss.1
j | MT_MassanSe, |
[Z)MT_Massonos7 4

[Z|MT_Masson0sa.t

MT_Massan? tif

i

"Tiff [adjustable fle

[~ Read only one Time Point.

Settings...

|.-'3.II Filez [auto format detection] [7.7] ﬂ
igz]'" Reader Configuration

Rezampling Dpen...

Open

>
=T
Cancel
|
6



Loading Images in Imaris  Reading Tiff Series
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» Choose the order of reading the series.
» Choose the Dimension Sequence for Slices, Channels and Time
ports

M Series Reading Sequence - C:\Documents and Settings\seemaj\My Documentsisteve_haines\cra... E@@

Apply Automatic File Filkgr | |I::"-.D|:u:uments and 5ettingzhseemajttdy Documentshsteve_haineshcranialnerve_senies'cranialne
\
* Hif Apply |
File List Dimenzions File Arrangement
M arne \ » 2 Clices [£) Channel | Time Paint 1 »
cranialnerye. 0000,k 1 cranialherye2. 0000 bf
cranialherye?. 0007 ki 1 Channels [C] cranialherse2. 0007 ki
cranialherye?. 0002t . . cratialhersez. 0002 kf
cranialherye?. 0003k 1 Time Pirtts [T) cratialhersez. 0003 kf
cranialnerye?. 0004, tif 2 of 81 files uzed cranialherseZ. 0004, tf
cranialnerye. 0005,k cranialherseZ. 0005, kf
cranialnerve2. D006, tf Dimenszion Sequence cranialnerye. 0006, tif
cranialnerye?. 0007 tif ~ .1 cranialnersez. 0007 ki
cranialnerye?. 0008, ki cranialherse?. 0002 tf
cranialnerye?. 0009,k W E-T L cranialherseZ. 0003 tf
cranialnerve?. 007 0.k & .71 cranialnerse. 0070 kf
cranialnerves. 0017 ki cranialnerved 0071 tif
cranialnerves, 001 2.4 W - cranialnerve, 0071 2.tif
cranialnerves, 001 3. 4f ~T.z.r cranalnerve, 001 2.kf
cranialnerves, 001 4. 4f cranalnerve, 007 4.4
cranialneryed. 007 5.k W T-CE cranialherseZ. 0075 hf
cramialneryed. 001 6.k cranialheryeZ. 0076 hf
cranialherye?. 0077 ki cranialherse2 0077 kf
cranialherye?. 007 8.k cratialherse2. 0078 kf
cranialherye?. 007 9.k cratialherse2. 0079 kf
cranialneryed. D020,k W cranialhersez. 0020 kf W
ak. | Cancel |




M ﬁ Loading Images in Imaris
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Reading multiple channels:

Note 1:
If different channels are saved in multiple files with sequentially
numbered filenames, Imaris will automatically load all of them.

Otherwise, for additional channels-

Edit->AddChannels->Select file

Note 2:

Imaris does not support 16-bit tiff images.

- Save your images in 16-bit ‘unsigned’ format, or convert them to 8-
bit first and then load Imaris
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Display Properties Image Processing

I Display Adjustment

. .. e Changing display properties for
M Channel 1 brightness/contrast/opacity is not
permanent
e However, using the image
e processing functions change the
| A original dataset. They should be
PR used only to remove noise.

Range - Channel 2

kin: |.'-".238 Feset
b 2 |255.|:||:||:| Auto

Elend Opacity = 100.000 % [Ch 2]

:v"_ Channel 2
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Image Properties

I Image Properties
CEmET

Daka Set
-1 Channels
Channel 1
Channel 2
Thurmbnail
Pararmeters

8 bit [unzigned]

Rezample 30..

1 =
Date [Y'¥YY-MM-DD]

2005-03-23

Time [HH:MM:55.555]

[0k 00: 00,000

unknown -

Image Processing

e Edit->ImageProperties
e Change base colors for
each channel

e change dataset
geometry- resampling
and voxel sizes

10



I W Smoothing Image Processing
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Fe E mwfmm AT : « Gaussian. One voxel's intensity
& £ me 5 M is replaced by the weighted
o d Is replace ‘yt e weighted sum
S Toe 2 2 of the intensities of its

Srmap s and Chapml

neighbours. The weights in any
direction correspond to a bell
curve centered at the voxel's
position.

« Median. One voxel's intensity is
replaced by the median intensity
of its neighbours.

- Edge Preserving. Similar to
Gaussian but instead of filtering
all directions it only filters in
directions without gradient.

11



If*i ﬁ Edge Preserving Noise filter  Image Processing
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« Top: Original single section.
« Middle: Image filtered with Gaussian filter.

« Bottom: Image filtered with edge preserving
filter (EPF) using same filter width than for
Gaussian filter.

« The EPFisnotastandard kernel operation.
Instead the filter kernel is computed newly for
each voxel position to avoid filtering across
edges.

+ Benefit: While the noise removal effect
(smoothing) of the EPF is similarin areas of
more homogenous intensities it does not filter
across intensity gradients (edges).

« Thisfilter preseves the overall intensity in the
image. The integral of all voxel intensities
remains constant.

12



M ﬁ Undo Functions in Imaris
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» Before Imaris activates an image
processing function it stores the current
image for an eventual subsequent undo
operation.

* The number of undo steps can be
customized using the Preferences dialog
of the Edit menu.

* Increase the number for Maximum
MNumber of Commands in History™ to be
able to undo more than just the last
operation. Keep in mind that each undo
step require a full copy of all channels,
layers, and time points and adjust
accordingly.
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Surpass tools

ESL16.ims - Imaris 4.0 =Joed
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| File Edit View ImsgeFProcessing Surpass Help
Add T i ¥  Clipping Plane )
w—. E ﬁ W ] Contour Surface 5’ ;] - o ¢
Export Selected Objects... | d E
Cpen  Save @s... Snapshg Delete Selected Objects External Object rpass Coloc Bitplane AG
Fil t
No Object Selected F:.:::n
Group —Znam
Iso Surface 1=
Light Source i
Measurement Point bt
Ortho Slicer — Puinter
oo " Select
Topography ' Mavigate
Track o
Wolume ~igw
Key Frame
Apimation
™ Full Screen
Objects - Camera Type —
aJﬁJ°|:|?'I=%|D|T|@']| Delete...l L Qrthogc-nlal
/ ' Perspective
- - —Diraw Style——
Existing palette and [Pl Feaun =]
g - [~ box move
additional tools in Fionare:

Set Center ...

the surpass menu

Stereo ...

Time ﬁettings...l ﬂ ﬂ j I | 1




ﬁ Volume Visualization contd.

Yolume - Properties

kMaode
(" Blend o MIP

Threzhald
far first vizible channel

0 “‘i 255, 000

(¢ cutlow € cuthigh |51_|:||:||:| ﬂ

M

%

* Choose between MIP and Blend modes
 Cutoff threshold values to remove ‘black voxels’ from rendering
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I ﬁ Volume Visualization contd.
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Imaris needs three textures for a good volume visualisation, one for each
direction in space. The size of voxels should be the same in all x, y, z
directions. To do this:

e Find voxel sizes . Z size is often bigger that X and Y size.
Edit - >Image Properties - >Geometry->Size Coordinates

e Use this formula to calculate the new number of Z layers to get the
desired Z voxelsize:

(Voxelsize Z / Voxelsize Y)*Number of Z-Layers = Number of desired Z-
Layers

e Change Z to the result of the formula.
Edit - >Image Properties - >Size - Resample 3D

Example: Original Voxelsize X: 0.164600 Y: 0.164600 Z: 0.200000
Original Amount of Z-Layers 64
Apply formula: 0.2 7/ 0.164600 x 64 = 77,76
Resample Z to 78

New Voxelsize: X: 0.164600 Y: 0.164600 Z: 0.163636 16



Isosurfaces

e B

- sach

gl

[T Resample datazet

£ Standard Size
) Huick Size

[T Smooth dataset

Advanced Settings > |

232

= Adyaneed Sethings
Yarel size [Hrite

128 zl
M = [ 148s i
yo|18 :l' 11988

- ¥ | Fived ratio 2

| | WREEEEE T e it e 2

0.252 [Fatzaraty filter width

¥ | El5ze ohiects &t berder

I:I[§r Cancel

Imaris automatically
finds and sets a
threshold value for
each channel, but it
can be modified.
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M ﬁ Isosurfaces Image Segmentation

MINMNESOTA SUPERCOMPUTING INSTITUTE

Tip: Try superimposing the isosurface
with slice-

This helps to test whether the chosen
threshold level is good or not

Tip: If you are unable to get an
iIsosurface without getting too much
noise or losing too much information,
then try Connective baseline filter and
create isosurfaces again

Isosurfacse can also be used to detect spots.
Tip: Split All spots to create individual objects.
Collect statistics from Isosurface group object

18



1IN Image Segmentation
F SpOt Detection (from volume rendering)

MINMNESOTA SUPERCOMPUTING INSTITUTE

« Display image as a volume
[t eacond | component in Surpass to verify
e e the spot creation process.

« Add a spot component.

« Choose the channel in whcih
spots are to be detected.

« Choose the approximate spot
diameter.

E-« e o T « Define minimal brightness of the
EF%NJ spot's intensity maxima and see
O the disappearance of weak

EST - spots.

19



ﬁ Tracking Objects Image measurements

Where do cells migrate?

Are all cells moving with the same speed?

Are all organells moving in the same direction?
Are there any dividing cells”?

Are vesicle growing over time?

Who does the time series look with system drift
corrected?

How do | display and show the behaviour of
hundreds of tracks?

20
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Tracking Methods

Image Segmentation

Tracking Methods in Imaris
T[9]

The surface tracking system tracks

SurfaceObjects from one time
point to the next.

Objects can merge and split.

Volume/intensity changes are
automatically computed, displayed,
and reported.

The surfaces of one object in two
consecutive time points must
overlap for automatic tracking.

+ 3
oy
&

L

The spot tracking identifies
Jelatively” bright spotsin a local
surrounding.

The tracking subsystem makes
assumption on the future
location ofthe object based on
its past movement.

Objects can be tracked even
though they are not overlapping
in two consecutive time points.

Spot tracking works well on
objects touching each other.

21



ﬁ Colocalization
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Simple Qualitative Colocalization

 Stain two objects of interest that interact in-vitro

 Manually adjust brightness contrast values and view overlapping regions
as colocalised.

This method is random and does not give statistical proof

22



Colocalization

-
-
o . BITPLANE AG
-

L J——ﬂl‘

Courtesy: Bitplane Inc.
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Image Segmentation

Automated, standardized
determination of colocalized
voxels.

Manual selection of thresholds on
histogram or on image.

Full integration with other Imaris
modules.

Processes 2D, 3D, and 4D images
(with ImarisTime).

Histograms of 2D, 3D (and 4D with
ImarisTime).

Real-time feedback on changes in
selection.

Display of colocalized voxels with
original channels as defined in
channel visibility editor.

Advanced visualization in
combination with Surpass.
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ﬁ Automatic Th resholding Colocalization

MINNESOTA SUPERCOMPUTING INSTITUTE

» Exclude unspecific staining- Set a threshold value in one channel to mask
the entire image, prior to automatic thresholding

 Click Automatic Thresholding

» The software analyzes a pair of theresholds just that voxels above this show
a positive spatial correlation. i.e. r=0 at this pair. This mean that’s voxels
above this pair stain the same structure.

25



Automatic Thresholding

K

i--ﬁsharing vI

1

F

Threshald

53.00 _i

0.41 % of data zelected

T

Channel B
| Charnel 2 - tubuiin
Threshold

47.00

15 % of data zelected

2

Ready

/

0.03 % of data selected

Coloc Volurne Statistics

Quantity | W alue |
nurnber of colocalized vosels 535

¥ of ROI colocalized 003%
% wolume & above thieshold colocalized  5.25 %
% wolume B abowe threzhold colocalized 246 %
% matenial & above threshold colocalized  9.84 %
% matenal B above threshold colocalized 223 %
% of ROI material & colocalized 099 %

Define Region of Interest [RON)
| Mask dataset

Channel 1 - kinstoc i

"N S e
=] r {1 ¥ ‘ o F 2
0 A NELE r, L&)
> 8 @ N W B e :
Cpen  Save as... Snapshot Slice Section Gallery Easy 3D Full 30 Surpass Coloc Bitplane AG
Channel & 2D Histogram Colocalization

Selection mode
+ Threshold
™ Polyge

.&utomatic threshalding

Hiztogram mode

™ Single slice

(+ Single time point
Al time points
Histagram options

v |gnore border bing
IV Logarithmic
I+ Color coded

Coloc intensities
f+ Source channels

™ Comstart value

Build Coloc Channel

Zoom: 2.32

Colocalization

2d histogram

adjustment

Masking
irrelevant

thresholds to
reduce subset
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Ifﬂf 4 ﬁ Imaris Coloc Measurements/Colocalization
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Image Properties

Data Set
T Chaz;j;nel { Mame |E-:|I|:u:a|izati|:|n Fresul]
Chaningl 2 Description SnurceIEhannels: 1&2
Channel 3 Selection Method: Threshold
Channel 4 Threshold &; 40.00 Threshold B: 43.00
Channel 5
Thumbnail oy
e o Base color | Mapped color  Coloc Statistics
time frame 1 Eadl
number of colocalized voxels 1739
% of dataset colocalized 0.08
% of ROI colocalized 0.08
%% of volume & above threshold colocalized 11.00
% of volume B above threshold colocalized 6.05
&% of material A above threshold colocalized 11.51
% of material B above threshold colocalized 5.66
%% of ROI material A colocalized 2.07
%% of ROI material B colocalized 1.59
channel correlation in dataset volume 0.3811
channel correlation in ROT volume 0.3811 [ 4 |
4 | Cancel |
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ﬁ Measurements in Imaris Measurements
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Measurements are integrated at several places in Imaris
Mostly found as a ‘Statistics’ tab in
Spots( count, radius, position),
Tracks( length, no of tracks),
Surfaces( surface areas, counts)
e Measure distances by selecting points on surfaces or slice
» Export statistics to excel or save as tab delimited text for further analysis
e Use programs like Tecplot, Matlab, SigmaPlot
e Click open Excel Tab to get Pivot Tables

28



ﬁ Saving your work and Graphics
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e It is as simple as taking a snapshot

e Collect images from Slice, Easy3d or surpas sviews

» Make sure that Offscreen rendering in your dsiplay preferences.
Edit->Preferences->Display

e Save images in tiff format for higher quality

« If you have made changes to your original set, like filtering etc.- you can
save the modified set. File->Save As- > Select any image format,
preferably tiff or pic

e To save the scene, File-> ExportScene

» Retrieve the scene by File->Load Scene

» Retrieve the Image file by File->Open

29



M ﬁ Creating Movies
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 Select the Animation module

A timeline appears the bottom.

e Set number of frames depending on the duration of your movie

* Click Settings to change your rendering preferences- this is only to
optimize memory and refresh rates; not the actual rates

* Navigate in the viewer, move to frame position in the timeline and add
keyframe

» Keep adding keyframes until you have finished the ‘choreography’

e You can add, delete or slide keyframe by selecting in the timeline

* When done, hit the red record button. Save movie

k.ew Frame drimation
4 Add | | | 100 Frames
Auto Digtibute MJ Seftings... ﬂﬂ

Ready Zoom;
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ﬁ More In Imaris
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ImarisXT allows an eXTension of Imaris
Can be used to write one’s own modules as plugins
Interfaces with Matlab- The modules can be written in

Matlab and brought in Imaris

31



IT’ 1 W References/Help

MINMNESOTA SUPERCOMPUTING INSTITUTE

www.bitplane.com

Bitplane’s FAQ server
http://flash.bitplane.com/support/fags/fags.cfm

Advanced Imaging Centers- NAAIC

http://www.advanced-imaging-center.org/naaic.html

Help at MSI-

Seema Jaisinghani
seemaj@msi.umn.edu
612-626-3451 (direct)

help@msi.umn.edu
612-626-0802(help line)
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